🚀 Generate full stack React, Vue, Angular applications easily with our new Web Application Generator! 🚀

Impossible to start project

Gravatar

Hello,

I get the code from GitHub, installed latest version of Angular and Yarn. I get the packages no problem. But when I do a 'yarn start' I get this error below (error1). Then I take the .zip file I did the same operation (yarn install, yarn run)

I tried with anguler 11.0.0 but same result.

How can I fix this ?

Thanks,

Error with Zip file [error] Error: Script file nodemodules/skycons/skycons.js does not exist. at C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:161:23 at Array.reduce () at Object.getCommonConfig (C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:153:108) at C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\dev-server\index.js:89:23 at generateWebpackConfig (C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:45:49) at processTicksAndRejections (internal/process/taskqueues.js:93:5) at async generateBrowserWebpackConfigFromContext (C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:136:20) at async Object.generateI18nBrowserWebpackConfigFromContext (C:\Users\Chris\Downloads\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:77:20) at async setup (C:\Users\Chris\Downloads\flatlogic-sing-app-angular\node_modules\@angular-devkit\build-angular\src\dev-server\index.js:87:47)

Error with GitHub Clone [error] Error: Script file nodemodules/bootstrap-application-wizard/src/bootstrap-wizard.js does not exist. at C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:161:23 at Array.reduce () at Object.getCommonConfig (C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:153:108) at C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\dev-server\index.js:89:23 at generateWebpackConfig (C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:45:49) at processTicksAndRejections (internal/process/taskqueues.js:93:5) at async generateBrowserWebpackConfigFromContext (C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:136:20) at async Object.generateI18nBrowserWebpackConfigFromContext (C:\Users\Chris\Downloads\sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:77:20) at async setup (C:\Users\Chris\Downloads\sing-app-angular\node_modules\@angular-devkit\build-angular\src\dev-server\index.js:87:47)

User profile image

Hi, Kris-I! Thank you for your message, we are dealing with the problem now and will respond as soon as possible.

User profile image

Hi, Kris-I!

We try to reproduce your error, on different systems, with different versions of packages, but the project always runs. Can you describe, step by step, the sequence of actions leading to the error?

Gravatar

Hello,

Yarn version : 1.22.10

Angular version : Angular CLI: 11.2.10 Node: 14.16.1 OS: win32 x64

Angular: 11.2.11 ... animations, common, compiler, compiler-cli, core, forms ... language-service, platform-browser, platform-browser-dynamic ... router Ivy Workspace: Yes

Package Version

@angular-devkit/architect 0.1102.13 @angular-devkit/build-angular 0.1102.13 @angular-devkit/core 11.2.10 @angular-devkit/schematics 11.2.10 @angular/cli 11.2.10 @schematics/angular 11.2.10 @schematics/update 0.1102.10 rxjs 6.6.7 typescript 4.1.5

Below step by step.

  1. Create a C:\temp
  2. Copy the .zip content in the directory and rename it. Then I have c:\temp\flatlogic-sing-app-angular
  3. Open VS code via "code ." command on the directory (see previous point)
  4. In VS Code open terminal
  5. Type "yarn install" not work : yarn : File C:\Users\Chris\AppData\Roaming\npm\yarn.ps1 cannot be loaded. The file C:\Users\Chris\AppData\Roaming\npm\yarn.ps1 is not digitally signed. You cannot run this script on the current system. For more information about running scripts and setting execution policy, see aboutExecutionPolicies at https:/go.microsoft.com/fwlink/?LinkID=135170. At line:1 char:1

    • yarn install
    • ~~~~
      • CategoryInfo : SecurityError: (:) [], PSSecurityException
      • FullyQualifiedErrorId : UnauthorizedAccess
  6. I fixed point 5 by this command : Set-ExecutionPolicy -Scope Process -ExecutionPolicy Bypass

  7. yarn install is now working, I get some warnings during resolving packages (see below)

  8. yarn start is not working. I get this error : PS C:\Temp\flatlogic-sing-app-angular> yarn start yarn run v1.22.10 $ ng serve An unhandled exception occurred: Script file node_modules/jvectormap-world/jquery-jvectormap-world-mill-en.js does not exist. See "C:\Users\Chris\AppData\Local\Temp\ng-f3wGop\angular-errors.log" for further details. error Command failed with exit code 127. info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

    Log error content : [error] Error: Script file nodemodules/jvectormap-world/jquery-jvectormap-world-mill-en.js does not exist. at C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:161:23 at Array.reduce () at Object.getCommonConfig (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:153:108) at C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\dev-server\index.js:89:23 at generateWebpackConfig (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:45:49) at processTicksAndRejections (internal/process/taskqueues.js:93:5) at async generateBrowserWebpackConfigFromContext (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:136:20) at async Object.generateI18nBrowserWebpackConfigFromContext (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:77:20) at async setup (C:\Temp\flatlogic-sing-app-angular\node_modules\@angular-devkit\build-angular\src\dev-server\index.js:87:47)

Warning on point 7 warning [email protected]: [email protected] @angular-devkit/build-angular > webpack-dev-server > [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. warning @angular-builders/custom-webpack > @angular-devkit/build-angular > webpack-dev-server > chokidar > [email protected]: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. warning @angular-builders/custom-webpack > @angular-devkit/build-angular > stylus > css-parse > css > [email protected]: Please see https://github.com/lydell/urix#deprecated warning @angular-builders/custom-webpack > @angular-devkit/build-angular > stylus > css-parse > css > source-map-resolve > [email protected]: Please see https://github.com/lydell/urix#deprecated warning @angular-builders/custom-webpack > @angular-devkit/build-angular > webpack > watchpack > watchpack-chokidar2 > [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. warning @angular-builders/custom-webpack > @angular-devkit/build-angular > stylus > css-parse > css > source-map-resolve > [email protected]: https://github.com/lydell/resolve-url#deprecated warning @angular/cli > universal-analytics > [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 warning @angular/cli > pacote > @npmcli/run-script > node-gyp > [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 warning @angular/cli > universal-analytics > request > [email protected]: this library is no longer supported warning @types/[email protected]: Types for the Google Maps browser API have moved to @types/google.maps. Note: these types are not for the googlemaps npm package, which is a Node API. warning napa > download > gulp-decompress > [email protected]: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5 warning [email protected]: TSLint has been deprecated in favor of ESLint. Please see https://github.com/palantir/tslint/issues/4534 for more information. [2/4] Fetching packages... info [email protected]: The platform "win32" is incompatible with this module. info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. info [email protected]: The platform "win32" is incompatible with this module. info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. [3/4] Linking dependencies... warning " > [email protected]" has unmet peer dependency "[email protected]^4.0.0 || ^5.0.0". warning " > @agm/[email protected]" has incorrect peer dependency "@angular/[email protected]^9.1.0 || ^10.0.0". warning " > @agm/[email protected]" has incorrect peer dependency "@angular/[email protected]^9.1.0 || ^10.0.0". warning " > [email protected]" has incorrect peer dependency "[email protected]^1.14.6". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^3.5.x". warning " > [email protected]" has incorrect peer dependency "@angular/[email protected]^8.2.9". warning " > [email protected]" has incorrect peer dependency "@angular/[email protected]^8.2.9". warning " > [email protected]" has unmet peer dependency "[email protected]^4.5.0". warning "ng2-datetime > [email protected]" has unmet peer dependency "@popperjs/[email protected]^2.9.2". warning "ngx-chips > [email protected]" has incorrect peer dependency "@angular/[email protected]^8.0.0". warning "ngx-chips > [email protected]" has incorrect peer dependency "@angular/[email protected]^8.0.0". warning "ngx-chips > [email protected]" has incorrect peer dependency "@angular/[email protected]^8.0.0". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > [email protected]" has incorrect peer dependency "[email protected]^8.2.15". warning "@angular-builders/custom-webpack > @angular-devkit/build-angular > cssnano > cssnano-preset-default > postcss-merge-longhand > [email protected]" has incorrect peer dependency "[email protected]^8.2.15".

User profile image

Try deleting the file 'C:\Users\Chris\AppData\Roaming\npm\yarn.ps1'.

After that clean the cache with the command "npm cache clean"

And then try the installation again

Gravatar
  1. Deleted the file : C:\Users\Chris\AppData\Roaming\npm\yarn.ps1
  2. I did "npm cache clean "npm cache clean --force"
  3. yarn install is working (even if I get some warnings)
  4. yarn start PS C:\Temp\flatlogic-sing-app-angular> yarn start yarn run v1.22.10 $ ng serve An unhandled exception occurred: Script file node_modules/jvectormap-world/jquery-jvectormap-world-mill-en.js does not exist. See "C:\Users\Chris\AppData\Local\Temp\ng-aMdao7\angular-errors.log" for further details. error Command failed with exit code 127. info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

The log content is : [error] Error: Script file nodemodules/jvectormap-world/jquery-jvectormap-world-mill-en.js does not exist. at C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:161:23 at Array.reduce () at Object.getCommonConfig (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\webpack\configs\common.js:153:108) at C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\dev-server\index.js:89:23 at generateWebpackConfig (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:45:49) at processTicksAndRejections (internal/process/taskqueues.js:93:5) at async generateBrowserWebpackConfigFromContext (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:136:20) at async Object.generateI18nBrowserWebpackConfigFromContext (C:\Temp\flatlogic-sing-app-angular\nodemodules\@angular-devkit\build-angular\src\utils\webpack-browser-config.js:77:20) at async setup (C:\Temp\flatlogic-sing-app-angular\node_modules\@angular-devkit\build-angular\src\dev-server\index.js:87:47)

User profile image

Please update the project from github and try again

Gravatar

Alleluia that's work from the git version :)

Thanks,

Cookie Consent

By continuing to browse or by clicking 'OK', you agree to the storing of cookies on your device to enhance your site experience and for analytical purposes. To learn more about how we use cookies, please see our cookies policy.