🚀 Generate full stack React, Vue, Angular applications easily with our new Web Application Generator! 🚀

How to make this app work ? Getting error while running yarn install command : Could not load the Visual C++ component "VCBuild.exe

Gravatar

yarn install v1.22.10 [1/4] Resolving packages... [2/4] Fetching packages... info [email protected]: The platform "win32" is incompatible with this module. info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. [3/4] Linking dependencies... warning "@amcharts/amcharts4 > [email protected]" has unmet peer dependency "[email protected]^2.1.0". warning "@amcharts/amcharts4 > [email protected]" has unmet peer dependency "[email protected]^13.0.0". warning "@amcharts/amcharts4 > [email protected]" has unmet peer dependency "[email protected]^0.1.27". warning " > [email protected]" has unmet peer dependency "[email protected] - 3". warning " > [email protected]" has unmet peer dependency "[email protected]^1.12.9". warning " > [email protected]" has incorrect peer dependency "[email protected]^6.0.0". warning " > [email protected]" has incorrect peer dependency "[email protected]^4.3.1". warning " > [email protected]" has unmet peer dependency "[email protected]^15.5.7". warning " > [email protected]" has incorrect peer dependency "[email protected]^0.14.0 || ^15.0.0". warning " > [email protected]" has unmet peer dependency "[email protected]^3.4.4". warning " > [email protected]" has unmet peer dependency "[email protected] || 4.x.x". warning " > [email protected]" has incorrect peer dependency "[email protected] || 0.14.x || ^15.0.0-0 || 15.x.x". warning " > [email protected]" has incorrect peer dependency "[email protected] || 0.14.x || ^15.0.0-0 || 15.x.x". warning "react-draft-wysiwyg > [email protected]" has unmet peer dependency "[email protected] || 4.x.x". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^3.0.0". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^2.1.29". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^15.0.0 || ^16.0.0". warning " > [email protected]" has unmet peer dependency "[email protected]^15.0.0". warning "react-joyride > [email protected]" has unmet peer dependency "[email protected]^15.0.0". warning " > [email protected]" has incorrect peer dependency "[email protected]^0.14.0 || ^15.0.0-0". warning "react-shuffle > [email protected]" has incorrect peer dependency "[email protected]^15.4.2". warning " > [email protected]" has unmet peer dependency "[email protected]^7.3.0". warning " > [email protected]" has unmet peer dependency "[email protected]>= 16.8.0". warning " > [email protected]" has unmet peer dependency "@typescript-eslint/[email protected]". warning " > [email protected]" has unmet peer dependency "@typescript-eslint/[email protected]". warning " > [email protected]" has incorrect peer dependency "[email protected]". [4/4] Building fresh packages... [1/2] ⢀ core-js error C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass: Command failed. Exit code: 1 Command: node scripts/build.js Arguments: Directory: C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass Output: Building: C:\Program Files\nodejs\node.exe C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\bin\node-gyp.js rebuild --verbose --libsassext= --libsasscflags= --libsassldflags= --libsasslibrary= gyp info it worked if it ends with ok gyp verb cli [ gyp verb cli 'C:\Program Files\nodejs\node.exe', gyp verb cli 'C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\bin\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsassext=', gyp verb cli '--libsasscflags=', gyp verb cli '--libsassldflags=', gyp verb cli '--libsasslibrary=' gyp verb cli ] gyp info using [email protected] gyp info using [email protected] | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb which failed Error: not found: python2 gyp verb which failed at getNotFoundError (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (fs.js:183:21) gyp verb which failed python2 Error: not found: python2 gyp verb which failed at getNotFoundError (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (fs.js:183:21) { gyp verb which failed code: 'ENOENT' gyp verb which failed } gyp verb check python checking for Python executable "python" in the PATH gyp verb which failed Error: not found: python gyp verb which failed at getNotFoundError (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (fs.js:183:21) gyp verb which failed python Error: not found: python gyp verb which failed at getNotFoundError (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (fs.js:183:21) { gyp verb which failed code: 'ENOENT' gyp verb which failed } gyp verb could not find "python". checking python launcher gyp verb check python launcher python executable found: "C:\Python27\python.exe" gyp verb check python version C:\Python27\python.exe -c "import sys; print "2.7.15 gyp verb check python version .%s.%s" % sys.version_info[:3];" returned: %j gyp verb get node dir no --target version specified, falling back to host node version: 14.15.4 gyp verb command install [ '14.15.4' ] gyp verb install input version string "14.15.4" gyp verb install installing version: 14.15.4 gyp verb install --ensure was passed, so won't reinstall if already installed gyp verb install version is already installed, need to check "installVersion" gyp verb got "installVersion" 9 gyp verb needs "installVersion" 9 gyp verb install version is good gyp verb get node dir target node version installed: 14.15.4 gyp verb build dir attempting to create "build" dir: C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build gyp verb build dir "build" dir needed to be created? C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build gyp verb Not using VS2017: Could not use PowerShell to find VS2017 gyp verb build/config.gypi creating config file gyp verb build/config.gypi writing out config file: C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\config.gypi gyp verb config.gypi checking for gypi file: C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\config.gypi gyp verb common.gypi checking for gypi file: C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\common.gypi gyp verb gyp gyp format was not specified; forcing "msvs" gyp info spawn C:\Python27\python.exe gyp info spawn args [ gyp info spawn args 'C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\gyp\gypmain.py', gyp info spawn args 'binding.gyp', gyp info spawn args '-f', gyp info spawn args 'msvs', gyp info spawn args '-G', gyp info spawn args 'msvsversion=auto', gyp info spawn args '-I', gyp info spawn args 'C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\config.gypi', gyp info spawn args '-I', gyp info spawn args 'C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\addon.gypi', gyp info spawn args '-I', gyp info spawn args 'C:\Users\P5104881\.node-gyp\14.15.4\include\node\common.gypi', gyp info spawn args '-Dlibrary=sharedlibrary', gyp info spawn args '-Dvisibility=default', gyp info spawn args '-Dnoderootdir=C:\Users\P5104881\.node-gyp\14.15.4', gyp info spawn args '-Dnodegypdir=C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp', gyp info spawn args '-Dnodelibfile=C:\Users\P5104881\.node-gyp\14.15.4\<(targetarch)\node.lib', gyp info spawn args '-Dmodulerootdir=C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass', gyp info spawn args '-Dnodeengine=v8', gyp info spawn args '--depth=.', gyp info spawn args '--no-parallel', gyp info spawn args '--generator-output', gyp info spawn args 'C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build', gyp info spawn args '-Goutputdir=.' gyp info spawn args ] Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation gyp verb command build [] gyp verb build type Release gyp verb architecture x64 gyp verb node dev dir C:\Users\P5104881.node-gyp\14.15.4 gyp verb found first Solution file build/binding.sln gyp verb could not find "msbuild.exe" in PATH - finding location in registry gyp info spawn C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe gyp info spawn args [ gyp info spawn args 'build/binding.sln', gyp info spawn args '/nologo', gyp info spawn args '/p:Configuration=Release;Platform=x64' gyp info spawn args ] Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch. Build started 3/8/2021 9:02:33 PM. Project "C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln" on node 1 (default targets). ValidateSolutionConfiguration: Building solution configuration "Release|x64". MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it is installed elsewhere. [C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln] Done Building Project "C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln" (default targets) -- FAILED.

Gravatar

What does Visual C++ component "VCBuild.exe" has to do with this???????????????????

Gravatar

gyp verb build type Release gyp verb architecture x64 gyp verb node dev dir C:\Users\P5104881.node-gyp\14.15.4 gyp verb found first Solution file build/binding.sln gyp verb could not find "msbuild.exe" in PATH - finding location in registry gyp info spawn C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe gyp info spawn args [ gyp info spawn args 'build/binding.sln', gyp info spawn args '/nologo', gyp info spawn args '/p:Configuration=Release;Platform=x64' gyp info spawn args ] Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch. Build started 3/8/2021 9:31:12 PM. Project "C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln" on node 1 (default targets). ValidateSolutionConfiguration: Building solution configuration "Release|x64". MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it is installed elsewhere. [C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln] Done Building Project "C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\node_modules\node-sass\build\binding.sln" (default targets) -- FAILED.

Build FAILED.

"C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln" (default target) (1) -> (src\libsass target) -> MSBUILD : error MSB3428: Could not load the Visual C++ component "VCBuild.exe". To fix this, 1) install the .NET Framework 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it is installed elsewhere. [C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass\build\binding.sln]

0 Warning(s)
1 Error(s)

Time Elapsed 00:00:00.76 gyp ERR! build error gyp ERR! stack Error: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with exit code: 1 gyp ERR! stack at ChildProcess.onExit (C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\lib\build.js:262:23) gyp ERR! stack at ChildProcess.emit (events.js:315:20) gyp ERR! stack at Process.ChildProcess.handle.onexit (internal/childprocess.js:277:12) gyp ERR! System WindowsNT 10.0.19042 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsassext=" "--libsasscflags=" "--libsassldflags=" "--libsasslibrary=" gyp ERR! cwd C:\Users\P5104881\OneDrive - Ness Technologies\Pluggable Code\sing-app-react-v8.2.3\nodemodules\node-sass gyp ERR! node -v v14.15.4 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok Build failed with error code: 1

Gravatar
Michael Daineka

Hi!

Try following:

  • Install the latest versions of Python (it may not be related), and "Microsoft Visual C++ Redistributable for Visual Studio 2017", and of course, Node.js and NPM;
  • As Admin: $ cd "C:\Program Files\nodejs\nodemodules\npm" $ npm install node-gyp $ npm config set msvsversion 2015 --global Note that I have VS 2017, but configuring it as ver 2017 won't work. Not sure why.
  • As Admin: $ npm install -g node-sass
  • And finally, one last check: $ node-sass -v
Gravatar

Visual C++ related error has gone now However getting below error

warning " > [email protected]" has incorrect peer dependency "[email protected]". [4/4] Building fresh packages... [1/2] ⠐ core-js error C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-sass: Command failed. Exit code: 1 Command: node scripts/build.js Arguments: Directory: C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-sass Output: Building: C:\Program Files\nodejs\node.exe C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js rebuild --verbose --libsassext= --libsasscflags= --libsassldflags= --libsasslibrary= gyp info it worked if it ends with ok gyp verb cli [ gyp verb cli 'C:\Program Files\nodejs\node.exe', gyp verb cli 'C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsassext=', gyp verb cli '--libsasscflags=', gyp verb cli '--libsassldflags=', gyp verb cli '--libsasslibrary=' gyp verb cli ] gyp info using [email protected] gyp info using [email protected] | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb which failed Error: not found: python2 gyp verb which failed at getNotFoundError (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (node:fs:200:21) gyp verb which failed python2 Error: not found: python2 gyp verb which failed at getNotFoundError (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:13:12) gyp verb which failed at F (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:68:19) gyp verb which failed at E (C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:80:29) gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\which\which.js:89:16 gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\isexe\index.js:42:5 gyp verb which failed at C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\isexe\windows.js:36:5 gyp verb which failed at FSReqCallback.oncomplete (node:fs:200:21) { gyp verb which failed code: 'ENOENT' gyp verb which failed } gyp verb check python checking for Python executable "python" in the PATH gyp verb which succeeded python C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE gyp ERR! configure error gyp ERR! stack Error: Command failed: C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE -c import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack File "", line 1 gyp ERR! stack import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack ^ gyp ERR! stack SyntaxError: invalid syntax gyp ERR! stack gyp ERR! stack at ChildProcess.exithandler (node:childprocess:326:12) gyp ERR! stack at ChildProcess.emit (node:events:378:20) gyp ERR! stack at maybeClose (node:internal/childprocess:1067:16) gyp ERR! stack at Process.ChildProcess.handle.onexit (node:internal/childprocess:301:5) gyp ERR! System WindowsNT 10.0.19042 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsassext=" "--libsasscflags=" "--libsassldflags=" "--libsasslibrary=" gyp ERR! cwd C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\node_modules\node-sass gyp ERR! node -v v15.11.0 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok Build failed with error code: 1

Gravatar

Try to delete node_modules and install dependencies via yarn if you use npm.

Gravatar

Michael,

I have deleted the node_modules folder I deleted the yarn.lock file re ran yarn install

still getting the same error

yarn install v1.22.10 info No lockfile found. [1/4] Resolving packages... warning @amcharts/amcharts4 > pdfmake > pdfkit > fontkit > babel-runtime > [email protected]: [email protected] fbjs > [email protected]: [email protected] [email protected]: [email protected] [email protected]: No longer maintained, see more info in readme warning react-dev-utils > globby > fast-glob > micromatch > snapdragon > source-map-resolve > [email protected]: https://github.com/lydell/resolve-url#deprecated warning react-dev-utils > globby > fast-glob > micromatch > snapdragon > source-map-resolve > [email protected]: Please see https://github.com/lydell/urix#deprecated warning react-dropzone > attr-accept > [email protected]: [email protected] react-floater > [email protected]: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1 warning react-syntax-highlighter > [email protected]: Version no longer supported. Upgrade to @latest warning react-syntax-highlighter > lowlight > [email protected]: Version no longer supported. Upgrade to @latest warning reactstrap > react-popper > [email protected]: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1 warning [email protected]: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates. warning babel-jest > @jest/transform > jest-haste-map > [email protected]: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. warning [email protected]: This loader has been deprecated. Please use eslint-webpack-plugin warning [email protected]: please switch to a stable version warning jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > [email protected]: use String.prototype.padStart() warning jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142 warning jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 warning jest > jest-cli > jest-config > jest-environment-jsdom > jsdom > request > [email protected]: this library is no longer supported warning node-sass > [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 warning node-sass > node-gyp > [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142 warning webpack > watchpack > watchpack-chokidar2 > [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. warning webpack > watchpack > watchpack-chokidar2 > chokidar > [email protected]: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. warning webpack-dev-server > [email protected]: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. warning workbox-webpack-plugin > workbox-build > @hapi/[email protected]: Switch to 'npm install joi' warning workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/[email protected]: Moved to 'npm install @sideway/address' warning workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/[email protected]: This version has been deprecated and is no longer supported or maintained warning workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/[email protected]: This version has been deprecated and is no longer supported or maintained warning workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/[email protected]: This version has been deprecated and is no longer supported or maintained warning workbox-webpack-plugin > workbox-build > @hapi/joi > @hapi/topo > @hapi/[email protected]: This version has been deprecated and is no longer supported or maintained [2/4] Fetching packages... info [email protected]: The platform "win32" is incompatible with this module. info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. info [email protected]: The platform "win32" is incompatible with this module. info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. [3/4] Linking dependencies... warning " > [email protected]" has unmet peer dependency "[email protected] - 3". warning " > [email protected]" has unmet peer dependency "[email protected]^1.12.9". warning " > [email protected]" has incorrect peer dependency "[email protected]^6.0.0". warning " > [email protected]" has incorrect peer dependency "[email protected]^4.3.1". warning " > [email protected]" has unmet peer dependency "[email protected]^15.5.7". warning " > [email protected]" has incorrect peer dependency "[email protected]^0.14.0 || ^15.0.0". warning " > [email protected]" has unmet peer dependency "[email protected]^3.4.4". warning " > [email protected]" has unmet peer dependency "[email protected] || 4.x.x". warning " > [email protected]" has incorrect peer dependency "[email protected] || 0.14.x || ^15.0.0-0 || 15.x.x". warning " > [email protected]" has incorrect peer dependency "[email protected] || 0.14.x || ^15.0.0-0 || 15.x.x". warning "react-draft-wysiwyg > [email protected]" has unmet peer dependency "[email protected] || 4.x.x". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^3.0.0". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^2.1.29". warning " > [email protected]" has unmet peer dependency "@types/[email protected]^15.0.0 || ^16.0.0". warning " > [email protected]" has unmet peer dependency "[email protected]^15.0.0". warning "react-joyride > [email protected]" has unmet peer dependency "[email protected]^15.7.2". warning " > [email protected]" has incorrect peer dependency "[email protected]^0.14.0 || ^15.0.0-0". warning "react-shuffle > [email protected]" has incorrect peer dependency "[email protected]^15.4.2". warning " > [email protected]" has unmet peer dependency "[email protected]^7.3.0". warning "react-sortable-tree > [email protected]" has incorrect peer dependency "[email protected]^7.3.0". warning " > [email protected]" has unmet peer dependency "[email protected]>= 16.8.0". warning " > [email protected]" has unmet peer dependency "@typescript-eslint/[email protected]". warning " > [email protected]" has unmet peer dependency "@typescript-eslint/[email protected]". warning " > [email protected]" has incorrect peer dependency "[email protected]". [4/4] Building fresh packages... [1/3] ⠂ core-js [-/3] ⠄ waiting... error C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-sass: Command failed. Exit code: 1 Command: node scripts/build.js Arguments: Directory: C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-sass Output: Building: C:\Program Files\nodejs\node.exe C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js rebuild --verbose --libsassext= --libsasscflags= --libsassldflags= --libsasslibrary= gyp info it worked if it ends with ok gyp verb cli [ gyp verb cli 'C:\Program Files\nodejs\node.exe', gyp verb cli 'C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsassext=', gyp verb cli '--libsasscflags=', gyp verb cli '--libsassldflags=', gyp verb cli '--libsasslibrary=' gyp verb cli ] gyp info using [email protected] gyp info using [email protected] | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE" in the PATH gyp verb which succeeded C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE gyp ERR! configure error gyp ERR! stack Error: Command failed: C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE -c import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack File "", line 1 gyp ERR! stack import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack ^ gyp ERR! stack SyntaxError: invalid syntax gyp ERR! stack gyp ERR! stack at ChildProcess.exithandler (node:childprocess:326:12) gyp ERR! stack at ChildProcess.emit (node:events:378:20) gyp ERR! stack at maybeClose (node:internal/childprocess:1067:16) gyp ERR! stack at Process.ChildProcess.handle.onexit (node:internal/childprocess:301:5) gyp ERR! System WindowsNT 10.0.19042 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsassext=" "--libsasscflags=" "--libsassldflags=" "--libsasslibrary=" gyp ERR! cwd C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\node_modules\node-sass gyp ERR! node -v v15.11.0 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok

Gravatar

gyp verb command configure []

gyp verb check python checking for Python executable "C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE" in the PATH gyp verb which succeeded C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE gyp ERR! configure error gyp ERR! stack Error: Command failed: C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE -c import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack File "", line 1 gyp ERR! stack import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack ^ gyp ERR! stack SyntaxError: invalid syntax gyp ERR! stack gyp ERR! stack at ChildProcess.exithandler (node:childprocess:326:12) gyp ERR! stack at ChildProcess.emit (node:events:378:20) gyp ERR! stack at maybeClose (node:internal/childprocess:1067:16) gyp ERR! stack at Process.ChildProcess.handle.onexit (node:internal/childprocess:301:5) gyp ERR! System WindowsNT 10.0.19042 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsassext=" "--libsasscflags=" "--libsassldflags=" "--libsasslibrary=" gyp ERR! cwd C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\node_modules\node-sass gyp ERR! node -v v15.11.0 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok

Gravatar

Can you please provide versions for Node: node -v

Gravatar

node -v v15.11.0

Gravatar

Python Version 3.9.2 npm version { 'sing-app-react': '5.0.0', npm: '7.6.1', node: '15.11.0', v8: '8.6.395.17-node.27', uv: '1.41.0', zlib: '1.2.11', brotli: '1.0.9', ares: '1.17.1', modules: '88', nghttp2: '1.42.0', napi: '7', llhttp: '2.1.3', openssl: '1.1.1j', cldr: '38.1', icu: '68.2', tz: '2020d', unicode: '13.0' }

Gravatar

Thanks.

Can you also provide versions for node-gyp and node-sass?

Gravatar

C:\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda>node-gyp version

Usage: node-gyp [options]

where is one of: - build - Invokes msbuild and builds the module - clean - Removes any generated build files and the "out" dir - configure - Generates MSVC project files for the current module - rebuild - Runs "clean", "configure" and "build" all at once - install - Install node development files for the specified node version. - list - Prints a listing of the currently installed node development files - remove - Removes the node development files for the specified version

[email protected] C:\Users\P5104881\AppData\Roaming\npm\node_modules\node-gyp [email protected]

Gravatar

C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda>node-sass -v node-sass 5.0.0 (Wrapper) [JavaScript] libsass 3.5.5 (Sass Compiler) [C/C++]

Gravatar

node-gyp -v v7.1.2 node-sass 5.0.0 (Wrapper) [JavaScript]

Gravatar

Hi, vikasbasraness! Can you describe step by step what you did, how you started the project? We are trying to reproduce this error on different configurations and plugin versions, but nothing works )

Gravatar

Steps:

1) Downloaded the zip 2) installed NPM/Node.js 3) ran yarn install 4) started getting errors related to VC++ etc 5) ran install --global windows-build-tools (realized the command is not able to complete the execution), hence i ran the two files downloaded in the C:\Users\P5104881.windows-build-tools 6) Installed python-2.7.15.amd64 from command prompt 7) install vsBuildTools manually from command prompt 8) still was getting error related to VC++ 9) Followed Michael suggestion and reinstalled everything Install the latest versions of Python (it may not be related), and "Microsoft Visual C++ Redistributable for Visual Studio 2017", and of course, Node.js and NPM; As Admin: $ cd "C:\Program Files\nodejs\nodemodules\npm" $ npm install node-gyp $ npm config set msvsversion 2015 --global Note that I have VS 2017, but configuring it as ver 2017 won't work. Not sure why. As Admin: $ npm install -g node-sass And finally, one last check: $ node-sass -v 10) uninstalled python 2.7.15 11) yarn install 12) getting error related to :\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE gyp ERR! configure error gyp ERR! stack Error: Command failed: C:\Users\P5104881\AppData\Local\Programs\Python\Python39\python.EXE -c import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack File "", line 1 gyp ERR! stack import sys; print "%s.%s.%s" % sys.versioninfo[:3]; gyp ERR! stack ^ gyp ERR! stack SyntaxError: invalid syntax gyp ERR! stack gyp ERR! stack at ChildProcess.exithandler (node:childprocess:326:12) gyp ERR! stack at ChildProcess.emit (node:events:378:20) gyp ERR! stack at maybeClose (node:internal/childprocess:1067:16) gyp ERR! stack at Process.ChildProcess.handle.onexit (node:internal/childprocess:301:5) gyp ERR! System WindowsNT 10.0.19042 gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-gyp\bin\node-gyp.js" "rebuild" "--verbose" "--libsassext=" "--libsasscflags=" "--libsassldflags=" "--libsasslibrary=" gyp ERR! cwd C:\Users\P5104881\sing-app-react-v8.2.3\flatlogic-sing-app-react-1db31a39e28d8691b91c3246fbb96c7e377d8dda\nodemodules\node-sass gyp ERR! node -v v15.11.0 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok

Gravatar
vikasbasraness

Installed Python 2.7 Corrected the environment variable to point to Python 2.7 Installed BuildTools_Full for 2017 Installed VC++ 2017 restributable runtime

Solved
Cookie Consent

By continuing to browse or by clicking 'OK', you agree to the storing of cookies on your device to enhance your site experience and for analytical purposes. To learn more about how we use cookies, please see our cookies policy.