🚀 Generate full stack React, Vue, Angular applications easily with our new Web Application Generator! 🚀

Node Sass Problem

Gravatar

I purchased the Sing app React template but I'm unable to run it, I get the following error:

./src/styles/theme.scss (./nodemodules/css-loader/dist/cjs.js??ref--6-oneOf-5-1!./nodemodules/postcss-loader/src??postcss!./node_modules/sass-loader/dist/cjs.js!./src/styles/theme.scss) Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (93) For more information on which environments are supported please see: https://github.com/sass/node-sass/releases/tag/v4.14.1

I checked the link for Node Sass github repo but didn't find useful information. I tried cleaning the cache trick already and it didn't work. The node saas version i have installed in the app is (copied form the package.json that comes with the Sing app): "node-sass": "4.14.1",

What is the expected fix for this?

Gravatar

I should mention too that I tried to remove node-sass, clean cache, reinstall it, then i get a new error: Error: Node Sass version 6.0.0 is incompatible with ^4.0.0.

So i'm not really sure what is the expected fix here. I thought this was supposed to be a plug and play theme.

Gravatar

Hi,

We are investigating the issue and will answer the question ASAP!

Best, Eugene

Gravatar

Hi R, please run this command => npm rebuild node-sass

Cookie Consent

By continuing to browse or by clicking 'OK', you agree to the storing of cookies on your device to enhance your site experience and for analytical purposes. To learn more about how we use cookies, please see our cookies policy.